w7, vs 2008, 32bit, building PCL 1.7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

w7, vs 2008, 32bit, building PCL 1.7

nenadpol
Hei,

windows 7
visual studio 2008
32bit

I was wondering if anybody managed to build PCL 1.7 using vs2008?
Dependences used?
Can you give me some pointers in that case.

Thanks
Nenad
Reply | Threaded
Open this post in threaded view
|

Re: w7, vs 2008, 32bit, building PCL 1.7

Friedrich Politz
There are your dependencies:

http://pointclouds.org/downloads/windows.html

There shouldn't be any problems. Can you give more details at what point exactly you are stuck?
Cheers,
Fred
Reply | Threaded
Open this post in threaded view
|

Re: w7, vs 2008, 32bit, building PCL 1.7

edwinzero
This post has NOT been accepted by the mailing list yet.
Hello Friedich,

I have some problem during compiling x64 pcl and I think it may be caused by cmake.
My system is WIN8 , with NET. 4, NET. 4.5, VS 2010, VS2012, VS2013;

Here is the screenshot of Cmake


I think maybe one or more of these parts cause error.
1. Is the OpenNI2 is good to use? Do I need to unistall OpenNI2. OpenNi2 is I install from someone else's prebuild all in one installer for vs2012... Both x86 and x64;
2. I have already disable the part of OpenNi in CMakeLists.txt
3. Pcap should include BUT i still get the WARNNING: io features related to pcap will be disabled.
4. About the with part. I just check these parts for Veloydne HDL laser scanner and I also want to have access with openni2... If you could tell me how to configure that will be super great.
5. I really don't know how to handle with the OLD and NEW that mentioned in the window below in the pic, is that will be a problem. I check CMakeLists.txt and find there is a define of OLD... But I don't know how to solve this part...


Thank you so much if you could give me answers to my problem!!!!!