unmet dependencies error when installing on ubuntu

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

unmet dependencies error when installing on ubuntu

zenified
This post was updated on .
Hello

I am trying to instal pcl via apt-get and was given a dependence error.
After looking through the error output via aptitude, I was shown the following error:

 The following packages have unmet dependencies:
 libpcl-recognition-1.7-dev : Depends: libpcl-feature-1.7-dev which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libpcl-1.7-all [Not Installed]                    
2)     libpcl-1.7-all-dev [Not Installed]                
3)     libpcl-all [Not Installed]                        
4)     libpcl-apps-1.7-dev [Not Installed]                
5)     libpcl-recognition-1.7-dev [Not Installed]      


I have been looking around but am unable to find a way to resolve this

Regards
 
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

Jochen Sprickerhof
Administrator
Hi zenified,

* zenified <[hidden email]> [2013-08-13 19:57]:

> I am trying to instal pcl via apt-get ans was given a dependence error.
> After looking through the error output via aptitude, I was shown the
> following error:
>
>  The following packages have unmet dependencies:
>  libpcl-recognition-1.7-dev : Depends: libpcl-feature-1.7-dev which is a
> virtual package.
> The following actions will resolve these dependencies:
>
>      Keep the following packages at their current version:
> 1)     libpcl-1.7-all [Not Installed]                    
> 2)     libpcl-1.7-all-dev [Not Installed]                
> 3)     libpcl-all [Not Installed]                        
> 4)     libpcl-apps-1.7-dev [Not Installed]                
> 5)     libpcl-recognition-1.7-dev [Not Installed]      

I've just pushed new versions fixing this typo. Should be there once
they are through the auto builders.

Sorry for the trouble,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

xvision
I'm running Ubuntu 12.04 - I waited until the auto builders where complete after version 1.7 was uploaded today

apt-get install libpcl-all
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpcl-all : Depends: libpcl-1.7-all but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Seems like the issue is still there....
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

Jochen Sprickerhof
Administrator
Hi xvision,

* xvision <[hidden email]> [2013-08-14 06:51]:

> I'm running Ubuntu 12.04 - I waited until the auto builders where complete
> after version 1.7 was uploaded today
>
> apt-get install libpcl-all
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  libpcl-all : Depends: libpcl-1.7-all but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
> Seems like the issue is still there....

Nop, I've used the wrong OpenNI version on quantal and precise, guess
that's the problem you are seeing. New version are one the way.

Cheers Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

zenified
Hi  Jochen

Thanks! I am looking forward to the update

Zen
lwi
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

lwi
This post has NOT been accepted by the mailing list yet.
I am having the same problem, using Mint 15 (i.e. ubuntu 13.4) 32bit.

so count me amongst those looking forward to an update!

Lwi
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

james
Administrator
In reply to this post by zenified
Hi,

I am having issues following the instructions here (for a new system) http://www.pointclouds.org/downloads/linux.html

odroid@odroid:~$ sudo apt-get install libpcl-all
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpcl-all : Depends: libpcl-1.7-all but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Is this an ongoing issue, due to the 1.7.1 release talk I saw on Developers, or something else?
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

Jochen Sprickerhof
Administrator
Hi James,

* james <[hidden email]> [2013-10-02 20:49]:

> /odroid@odroid:~$ sudo apt-get install libpcl-all
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  libpcl-all : Depends: libpcl-1.7-all but it is not going to be installed
> E: Unable to correct problems, you have held broken packages./

Which Ubuntu version? Try aptitude install libpcl-all to see why.

Cheers Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

james
Administrator
This is the result of your recommendation (I must admit, I am quite a Linux noob, but have worked with PCL on Windows quite a bit.)
The following NEW packages will be installed:
  libpcl-1.7-all{ab} libpcl-1.7-all-dev{ab} libpcl-all
0 packages upgraded, 3 newly installed, 0 to remove and 11 not upgraded.
Need to get 10.9 kB of archives. After unpacking 85.0 kB will be used.
The following packages have unmet dependencies:
 libpcl-1.7-all-dev : Depends: libpcl-apps-1.7-dev which is a virtual package.
                      Depends: libpcl-common-1.7-dev which is a virtual package.
                      Depends: libpcl-features-1.7-dev which is a virtual package.
                      Depends: libpcl-filters-1.7-dev which is a virtual package.
                      Depends: libpcl-geometry-1.7-dev which is a virtual package.
                      Depends: libpcl-io-1.7-dev which is a virtual package.
                      Depends: libpcl-kdtree-1.7-dev which is a virtual package.
                      Depends: libpcl-keypoints-1.7-dev which is a virtual package.
                      Depends: libpcl-octree-1.7-dev which is a virtual package.
                      Depends: libpcl-outofcore-1.7-dev which is a virtual package.
                      Depends: libpcl-people-1.7-dev which is a virtual package.
                      Depends: libpcl-recognition-1.7-dev which is a virtual package.
                      Depends: libpcl-registration-1.7-dev which is a virtual package.
                      Depends: libpcl-sample-consensus-1.7-dev which is a virtual package.
                      Depends: libpcl-search-1.7-dev which is a virtual package.
                      Depends: libpcl-segmentation-1.7-dev which is a virtual package.
                      Depends: libpcl-surface-1.7-dev which is a virtual package.
                      Depends: libpcl-tracking-1.7-dev which is a virtual package.
                      Depends: libpcl-visualization-1.7-dev which is a virtual package.
 libpcl-1.7-all : Depends: libpcl-1.7-bin which is a virtual package.
                  Depends: libpcl-1.7-doc but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libpcl-1.7-all [Not Installed]                    
2)     libpcl-1.7-all-dev [Not Installed]                
3)     libpcl-all [Not Installed]                        



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.


I have tried on both Ubuntu 13.04 and Ubuntu 12.11 images, using an ARM based system.
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

Jochen Sprickerhof
Administrator
* james <[hidden email]> [2013-10-02 23:42]:
> I have tried on both Ubuntu 13.04 and Ubuntu 12.11 images, using an ARM
> based system.

ARM is not supported on Launchpad, so we can't provide binaries for it.

Cheers Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

ViktorZ
This post has NOT been accepted by the mailing list yet.
I'm on a x64, ubuntu 12.04. Same problem as stated in the first post. Aptitude output: http://pastebin.com/yRwt4Sfq
I have selected Y in the prompt and it wouldn't install anything.
I have the ros-groovy-pcl package installed aswell, might this be a problem?

Greetings,
Viktor
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

ozgurovic
Hello,

I had the same problem. After the first prompt, you should press 'n'. Then once more I think that you will press 'n'. Third time you can press 'y', it will install the ps-engine first. Since the process was very long I could not keep a track of it, but I pressed yes at the second or the third time, and the package list was similar to yours. I had pcl installed at the end.

Best.
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

athoesen
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: unmet dependencies error when installing on ubuntu

dim_tz
In reply to this post by ozgurovic
I had the same issue too, and the solution was given by the 2nd option of aptitude ;)
I tried also the 1st and 3rd, but the solution was given by the 2nd :)