pcl normal.compute returning NaN values

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pcl normal.compute returning NaN values

mwsafdar90
This post has NOT been accepted by the mailing list yet.
 0
down vote
favorite
       

I am trying to merge point clouds from two frames into one bigger point cloud. I will use ICP for that but I understand I need to per-align the point clouds. I am trying to do it with PCL template_alignment code from:

http://pointclouds.org/documentation/tutorials/template_alignment.php

The program computes surface normals after loading pointcloud. It works fine for the sample data used in the code but for my own data the "norm_est.compute(*normals_)" statement on line 89 returns NaN values. I read on PCL library documention that if the function can't find the neighbouring points it will return NaN values. That is my question, why the program is unable to find neighbourung points and what do I do about it? I am using the same settings as in the code in the above link for radius search and other perimeters for normal estimation.My left Image and point cloud are given below. I have uploaded a coloured pointcloud for better visualization but for alignment purposes I am using point cloud without RGB and my pointcloud.ply file contains only xyz coordinates.
psi
Reply | Threaded
Open this post in threaded view
|

Re: pcl normal.compute returning NaN values

psi
This post has NOT been accepted by the mailing list yet.
NaNs values may appear when the depth sensor can't reach some far points. You can use removeNaNfromPointCloud option.