pcl 1.6 cannot compile with VTK 6.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

pcl 1.6 cannot compile with VTK 6.0

Yang YU
Hi,

I update the latest version of VTK from its source repository. The thing is the pcl can not be compiled.

The first error shows "pcl/trunk/io/src/vtk_lib_io.cpp:174: error: ‘class vtkPolyDataWriter’ has no member named ‘SetInput’".

Thanks,
Yang


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: pcl 1.6 cannot compile with VTK 6.0

Radu B Rusu
Administrator
Yang,

PCL is not compatible with VTK 6.0 just yet, mostly because VTK 6.0 hasn't been released yet. We're probably going to
target full PCL 2.0 compatibility for VTK 6.0.

Cheers,
Radu.

On 06/17/2012 03:55 PM, Yang YU wrote:

> Hi,
>
> I update the latest version of VTK from its source repository. The thing is the pcl can not be compiled.
>
> The first error shows "pcl/trunk/io/src/vtk_lib_io.cpp:174: error: ‘class vtkPolyDataWriter’ has no member named
> ‘SetInput’".
>
> Thanks,
> Yang
>
>
>
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users