openni_grabber.h not found

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

openni_grabber.h not found

Christopher Feltner

Hello!

 

I'm using PCL to connect to a Kinect camera. Right now, I'm just trying to build the OpenNi Grabber tutorial. While building I'm getting an error that openni_grabber.h is not found.

fatal error: 'pcl/io/openni_grabber.h' file not found
#include <pcl/io/openni_grabber.h>

I checked the directory in question and the file is indeed missing, but I'm not sure why. Is there an install option that I'm missing? When I try to install via Homebrew, I use the option –with-openni but Homebrew says that the pcl formula doesn’t have such an option.

I have installed OpenNi using Homebrew and this formula. I am using the Kinect v1.

 

Thank you!

 


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: openni_grabber.h not found

GreenSokrates
Have you exported the location of your openni installation?

For Linux Systems add the following to your ~/.bashrc:
export OPENNI2_INCLUDE=/pathtoyourinstall/Include
export OPENN2_REDIST=/pathtoyourinstall/Redist

after that pcl shoud compile with the openni flag set.





--
Sent from: http://www.pcl-users.org/
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users