installing dependencies for pcl in ubuntu 14.04

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

installing dependencies for pcl in ubuntu 14.04

shome
This post was updated on .
I found this link for compiling pcl: http://larrylisky.com/2014/03/03/installing-pcl-on-ubuntu/

It explains about installing dependencies of pcl. However it uses openni 1 for kinect sensor. also there are many packages listed in the link which are not stated in http://pointclouds.org/downloads/source.html(viz. mpi, libusb, libgtest-dev, freeglut3-dev, libxmu-dev libxi-dev, graphviz mono-complete, qt-sdk openjdk-7-jdk openjdk-7-jre)

I intend to use carmine 1.09 on ubuntu 14.04 64 bit. what changes need to be done to the instructions in the above link in order to compile it for carmine 1.09 on ubuntu 14.04.


Reply | Threaded
Open this post in threaded view
|

Re: installing dependencies for pcl in ubuntu 14.04

andersgb1
I checked my deps (PCL 1.7 PPA), and got some inputs:

1> libboost-all-dev can also be used
3> Here I have only libflann-dev
4> Here I have only libvtk5-dev
5> Only libqhull-dev
6> Here I have libopenni-dev and libopenni2-dev
7> I don't have that

Else:
- g++/clang
- cmake

On 17 December 2014 at 11:38, shome <[hidden email]> wrote:
to compile pcl on linux (ubuntu 14.04) we need to install boost, eigen,
flann, vtk, qhull, openni, cuda.

when i try to install using synaptic or apt-get there are multiple files for
all the dependencies.

The question is which files to install.my assumption is that i have to
install the following:

1> boost: libboost1.55-all-dev, libboost1.55-dev
2> eigen: libeigen3-dev
3>flann: libflann-dev(development),libflann1.8(runtime)
4>vtk: libvtk6(runtime),libvtk6-dev(header files)
5> qhull: libqhull6(shared lib),libqhull-dev
6> openni2: libopenni2-dev,libopenni2-0(I am using carmine 1.09)
7> cuda: ??

is the above list ok? is it needed to install qt before installing qhull &
vtk?





--
View this message in context: http://www.pcl-users.org/installing-dependencies-for-pcl-in-ubuntu-14-04-tp4036597.html
Sent from the Point Cloud Library (PCL) Users mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: installing dependencies for pcl in ubuntu 14.04

shome
please check the link in my first message. it seems to be a comprehensive list of pcl dependencies. but it is a bit old as i dont find some versions on ubuntu 14.04.
Reply | Threaded
Open this post in threaded view
|

Re: installing dependencies for pcl in ubuntu 14.04

VictorLamoine
Administrator
sudo apt-get install libopenni-dev libboost-all-dev libflann-dev libeigen3-dev libvtk5.8* libqhull-dev libusb-1.0 libgtest-dev

Is it ok now?
Reply | Threaded
Open this post in threaded view
|

Re: installing dependencies for pcl in ubuntu 14.04

shome
This post was updated on .
is libopenni2-dev not needed, is libopenni-dev enough? i intend to use carmine 1.09.

what about qt-sdk openjdk-7-jdk openjdk-7-jre? are they needed or redundant?

@victor:

what libs are needed to enable openni2?  i see the following libs in my ubuntu:

libopenni0                        libopenni-dev                     libopenni-sensor-pointclouds-dev  
libopenni2-0                      libopenni-java                    libopenni-sensor-primesense0      
libopenni2-dev                    libopenni-sensor-pointclouds0     libopenni-sensor-primesense-dev

i checked libopenni-dev.its version is mentioned as 1.54.0-7 which is openni1.