dependecies compile errors, cminpack and flann.

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

dependecies compile errors, cminpack and flann.

zoulzubazz
hey guys,
first off i dont know if this is the right place to bring this up, pardon me if not. Really want to get going with PCL but FLANN and cminpack are giving me a hard time. while compiling cminpack i get the following error dump, saying it cant find 'cmake/cminpack_utils.cmake' which is not in the source files.

CMake Error at CMakeLists.txt:8 (include):
  include could not find load file:
    /home/subashj1/kinfu/cminpack-1.2.2/cmake/cminpack_utils.cmake
CMake Error at CMakeLists.txt:11 (DISSECT_VERSION):
  Unknown CMake command "DISSECT_VERSION".
-- Configuring incomplete, errors occurred!

And flann installs with warnings. the 'flann.pc' file is present in '/usr/local/lib64/pkgconfig' but when 'pkg-config flann --libs' is passed it shows me the following,
'-L/usr/local/lib64 -lflann_cpp'  not '-L/usr/local/lib64 -lflann'

any input would help me sleep better, thank you very much.
zoul
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

Radu B Rusu
Administrator
I believe we stopped using cminpack a while ago. Can you please tell us more about which version of PCL you're trying to
use?

Thanks,
Radu.

On 06/13/2012 12:47 PM, zoulzubazz wrote:

> hey guys,
> first off i dont know if this is the right place to bring this up, pardon me
> if not. Really want to get going with PCL but FLANN and cminpack are giving
> me a hard time. while compiling cminpack i get the following error dump,
> saying it cant find 'cmake/cminpack_utils.cmake' which is not in the source
> files.
>
> CMake Error at CMakeLists.txt:8 (include):
>    include could not find load file:
>      /home/subashj1/kinfu/cminpack-1.2.2/cmake/cminpack_utils.cmake
> CMake Error at CMakeLists.txt:11 (DISSECT_VERSION):
>    Unknown CMake command "DISSECT_VERSION".
> -- Configuring incomplete, errors occurred!
>
> And flann installs with warnings. the 'flann.pc' file is present in
> '/usr/local/lib64/pkgconfig' but when 'pkg-config flann --libs' is passed it
> shows me the following,
> '-L/usr/local/lib64 -lflann_cpp'  not '-L/usr/local/lib64 -lflann'
>
> any input would help me sleep better, thank you very much.
> zoul
>
> --
> View this message in context: http://www.pcl-users.org/dependecies-compile-errors-cminpack-and-flann-tp4019295.html
> Sent from the Point Cloud Library (PCL) Users mailing list archive at Nabble.com.
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

zoulzubazz
thanks for getting back mate, its version 1.5.1, which i believe is the newest. also any suggestion for the flann problem, when i make PCL it says it cant find the flann library. thanks again.
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

Radu B Rusu
Administrator
It seems that you're using Linux. What flavor? We might already have precompiled binaries for you -- check out
http://www.pointclouds.org/downloads/linux.html.

Cheers,
Radu.

On 06/13/2012 01:02 PM, zoulzubazz wrote:

> thanks for getting back mate, its version 1.5.1, which i believe is the
> newest. also any suggestion for the flann problem, when i make PCL it says
> it cant find the flann library. thanks again.
>
> --
> View this message in context: http://www.pcl-users.org/dependecies-compile-errors-cminpack-and-flann-tp4019295p4019297.html
> Sent from the Point Cloud Library (PCL) Users mailing list archive at Nabble.com.
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

zoulzubazz
hey radu, thank you, upgraded to ubuntu12.04 yesterday. tried using the precompiled binaries before  the upgrade yesterday from (ubuntu11.10)
it comes back with following errors.

The following packages have unmet dependencies.
 libpcl-all : Depends: libpcl-1.5-all but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

if i could compile and install it that would be ace. thanks again.
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

Jochen Sprickerhof
Administrator
* zoulzubazz <[hidden email]> [2012-06-13 13:46]:
> hey radu, thank you, upgraded to ubuntu12.04 yesterday. tried using the
> precompiled binaries before  the upgrade yesterday from (ubuntu11.10)
> it comes back with following errors.
>
> The following packages have unmet dependencies.
>  libpcl-all : Depends: libpcl-1.5-all but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
> if i could compile and install it that would be ace. thanks again.

We do provide packages for Ubuntu 12.04 as well, maybe you have to
remove all PCL packages first and reinstall them afterwards.

Cheers Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: dependecies compile errors, cminpack and flann.

zoulzubazz
thanks guys turns out there were broken dependencies during upgrade, fixed that and now am up and running. cheers.