Upgrading to Ubuntu 12.04

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrading to Ubuntu 12.04

Hordur Johannsson
Hi

I'm thinking about upgrading to Ubuntu 12.04 soon. Have people
compiled PCL on Ubunut yet? Have you experienced any problems?

Thanks,
Hordur


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Radu B Rusu
Administrator
I run Ubuntu 12.04 and can compile anything without problems. We're always ahead of the compiler curve as most of us get
the latest and greatest compilers the minute they get out.

Cheers,
Radu.

On 05/03/2012 03:22 PM, Hordur Johannsson wrote:

> Hi
>
> I'm thinking about upgrading to Ubuntu 12.04 soon. Have people
> compiled PCL on Ubunut yet? Have you experienced any problems?
>
> Thanks,
> Hordur
>
>
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

blackibiza
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Ivan Silva
I get this error, when running: "sudo apt-get install libpcl-all"

Os pacotes a seguir têm dependências não satisfeitas:
 libpcl-all : Depende: libpcl-1.5-all mas não vai ser instalado
E: Não foi possível corrigir problemas, você tem pacotes mantidos (hold) estragados


Any idea?
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Ivan Silva
The following packages have unmet dependencies:
 libpcl-all : Depends: libpcl-1.5-all but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Ivan Silva
Just fixed it with "sudo aptitude install libpcl-all"
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Mauro Bellone
Hi everyone,
After the upgrading to ubuntu 12.04 I got this:

Linking CXX executable main
/usr/bin/ld: warning: libvtkCommon.so.5.6, needed by /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict with libvtkCommon.so.5.8
/usr/bin/ld: warning: libvtkFiltering.so.5.6, needed by /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict with libvtkFiltering.so.5.8
/usr/bin/ld: warning: libvtkHybrid.so.5.6, needed by /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so, may conflict with libvtkHybrid.so.5.8
/usr/bin/ld: warning: libvtkRendering.so.5.6, needed by /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so, may conflict with libvtkRendering.so.5.8
[100%] Built target main

Segmentation fault (core dumped)

Anybody know something about this? are there some conflict with pcl visualization library ?
Thanks
Mauro
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Radu B Rusu
Administrator
 From the information you provided, my belief is that the segfault is a separate issue. We need a stack trace there.

The conflicts probably happens because the VTK version that your PCL binaries have been compiled against is 5.6, while
your system now has 5.8. The good news is that VTK seems to have decent ABI compatibility so your code should still work
without any problems.

Cheers,
Radu.

On 06/14/2012 12:20 AM, Mauro Bellone wrote:

> Hi everyone,
> After the upgrading to ubuntu 12.04 I got this:
>
> Linking CXX executable main
> /usr/bin/ld: warning: libvtkCommon.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict
> with libvtkCommon.so.5.8
> /usr/bin/ld: warning: libvtkFiltering.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict
> with libvtkFiltering.so.5.8
> /usr/bin/ld: warning: libvtkHybrid.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so,
> may conflict with libvtkHybrid.so.5.8
> /usr/bin/ld: warning: libvtkRendering.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so,
> may conflict with libvtkRendering.so.5.8
> [100%] Built target main
>
> Segmentation fault (core dumped)
>
> Anybody know something about this? are there some conflict with pcl
> visualization library ?
> Thanks
> Mauro
>
> --
> View this message in context: http://www.pcl-users.org/Upgrading-to-Ubuntu-12-04-tp3960636p4019320.html
> Sent from the Point Cloud Library (PCL) Users mailing list archive at Nabble.com.
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Jochen Sprickerhof
Administrator
In reply to this post by Mauro Bellone
* Mauro Bellone <[hidden email]> [2012-06-14 00:20]:

> Hi everyone,
> After the upgrading to ubuntu 12.04 I got this:
>
> Linking CXX executable main
> /usr/bin/ld: warning: libvtkCommon.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict
> with libvtkCommon.so.5.8
> /usr/bin/ld: warning: libvtkFiltering.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_io.so, may conflict
> with libvtkFiltering.so.5.8
> /usr/bin/ld: warning: libvtkHybrid.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so,
> may conflict with libvtkHybrid.so.5.8
> /usr/bin/ld: warning: libvtkRendering.so.5.6, needed by
> /usr/lib/gcc/x86_64-linux-gnu/4.6/../../../../lib/libpcl_visualization.so,
> may conflict with libvtkRendering.so.5.8
> [100%] Built target main
>
> Segmentation fault (core dumped)
>
> Anybody know something about this? are there some conflict with pcl
> visualization library ?

I guess you still have the PCL version for Ubuntu 11.10 installed,
change your apt sources to 12.04 as well (change oneiric to precise),
reinstall pcl and recompile your application.

Cheers Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Upgrading to Ubuntu 12.04

Mauro Bellone
Thanks, I solved it, just by removing and installing pcl again.
Cheers
Mauro