Running pcl_visualizer_demo on OSX shows only color blocks, vtk problem?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Running pcl_visualizer_demo on OSX shows only color blocks, vtk problem?

erictamlam
This post has NOT been accepted by the mailing list yet.
Hi folks,

I installed pcl on osx EI_Capitan 10.11.6 (15G1004) via homebrew with specific steps as follows:
brew install -vd sip libusb
brew install -vd boost --c++11
brew install -vd flann qhull glew qt pyqt openni openni2 openni2-freenectdriver vtk
brew install homebrew/science/pcl --with-openni --with-examples

Info of the installed pcl dependencies:
boost 1.64.0_1
cmake 3.8.1
eigen 3.3.3
flann 1.9.1_3
glew 2.0.0
libusb 1.0.21
openni 1.5.7.10
OpenNI-MacOSX-x64-2.2 Documentation Include Redist Samples Tools
openni2 2.2.0-debian
openni2-freenectdriver 0.4.1
pcl 1.8.0_6
pyqt 5.8.2
qhull 2015.2
qt 5.8.0_2
sip 4.19.2
vtk 7.1.1_1

The building process and installation worked out. But when I attempted to run the pcl_visualizer_demo provided by the official website: http://pointclouds.org/documentation/tutorials/pcl_visualizer.php 
The 3D viewer shows only color blocks, not point clouds.


The project was built through cmake. CMakeLists.txt is configured to be:
cmake_minimum_required(VERSION 2.6 FATAL_ERROR)

project(pcl_visualizer_demo)
find_package(PCL 1.2 REQUIRED)
include_directories(${PCL_INCLUDE_DIRS})
link_directories(${PCL_LIBRARY_DIRS})
add_definitions(${PCL_DEFINITIONS})
IF (APPLE)
    FIND_PATH( GLEW_INCLUDE_DIR glew.h
      /System/Library/Frameworks/GLEW.framework/Versions/A/Headers
      ${OPENGL_LIBRARY_DIR}
    )
    SET(GLEW_GLEW_LIBRARY "-lGLEW" CACHE STRING "GLEW library for OSX")
    SET(GLEW_cocoa_LIBRARY "-framework Cocoa" CACHE STRING "Cocoa framework for OSX")
ENDIF (APPLE)
add_executable (pcl_visualizer_demo pcl_visualizer_demo.cpp)
target_link_libraries (pcl_visualizer_demo ${PCL_LIBRARIES})

Is this problem related to vtk? How can I fix it?
Millions of thx in advance:)
Reply | Threaded
Open this post in threaded view
|

Re: Running pcl_visualizer_demo on OSX shows only color blocks, vtk problem?

gpeytavi
This post has NOT been accepted by the mailing list yet.
The visualizer is simply initialized with too much of "zoom".

Try clicking the visualizer window and scrolling/zooming out ;)