Realsense Grabber Dependency Error Cmake

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Realsense Grabber Dependency Error Cmake

maestro157
This post was updated on .
I am trying to compile PCL with realsense grabber dependency on Ubuntu
17.10., cmake is searching for "RSSDK" in cmake.modules, but realsense
legacy is saved there as "realsense" and the current realsense2 library is
saved as "realsense2". Is that an error in the cmake file or am I missing
something?

the exact line in CMakeLists.txt Line 302:
PCL_ADD_GRABBER_DEPENDENCY("RSSDK" "RealSense SDK support")


and the corresponding macro in pcl/cmake/pcl_targets.cmake Line 857

macro(PCL_ADD_GRABBER_DEPENDENCY _name _description)
    string(TOUPPER ${_name} _name_capitalized)
    option(WITH_${_name_capitalized} "${_description}" TRUE)
    if(WITH_${_name_capitalized})
      find_package(${_name})
      if (NOT ${_name_capitalized}_FOUND)
        set(WITH_${_name_capitalized} FALSE CACHE BOOL "${_description}"
FORCE)
        message(WARNING "${_description}: not building because ${_name} not
found")
      else()
        set(HAVE_${_name_capitalized} TRUE)
        include_directories(SYSTEM "${${_name_capitalized}_INCLUDE_DIRS}")
      endif()
    endif()
endmacro(PCL_ADD_GRABBER_DEPENDENCY)


The cmake config and target files for realsense:
realsenseConfig.cmake
realsenseTargets.cmake
realsenseTargets-noconfig.cmake

The cmake config and target files for realsense2:
realsense2Config.cmake
realsense2Targets.cmake
realsense2Targets-noconfig.cmake


Thanks for your help





--
Sent from: http://www.pcl-users.org/
_______________________________________________
PCL-users@pointclouds.org / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users