Problems installing PCL 1.7.1 using PPA and Ubuntu

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems installing PCL 1.7.1 using PPA and Ubuntu

Altella
Hello all;

After not being able to solve linker problems with windows, I am trying to install PCL 1.7.1 in Ubuntu using PPA.
I have added the repository, and done the update, but when installing using:
sudo apt-get install libpcl-all

I receive errors (I have the console in Spanish, I translate the messages, maybe no are exactly the same in English):

 The following packages have unfulfilled dependencies:
libpcl-all: Depends: libpcl-1.7-all but it will not be installed.
Problems could not be solved, there are broken packages.

I have tried to fulfill dependencies, but the error is appearing recursively for every package y try to install...

I would appreciate any kind of help,

Best regards,
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing PCL 1.7.1 using PPA and Ubuntu

VictorLamoine
Administrator
Hello,

Do you have backports repo enbaled ?
First try sudo apt-get -f install



2014-01-30 Altella <[hidden email]>
Hello all;

After not being able to solve linker problems with windows, I am trying to
install PCL 1.7.1 in Ubuntu using PPA.
I have added the repository, and done the update, but when installing using:
sudo apt-get install libpcl-all

I receive errors (I have the console in Spanish, I translate the messages,
maybe no are exactly the same in English):

 The following packages have unfulfilled dependencies:
libpcl-all: Depends: libpcl-1.7-all but it will not be installed.
Problems could not be solved, there are broken packages.

I have tried to fulfill dependencies, but the error is appearing recursively
for every package y try to install...

I would appreciate any kind of help,

Best regards,



--
View this message in context: http://www.pcl-users.org/Problems-installing-PCL-1-7-1-using-PPA-and-Ubuntu-tp4031998.html
Sent from the Point Cloud Library (PCL) Users mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing PCL 1.7.1 using PPA and Ubuntu

Jochen Sprickerhof
Administrator
In reply to this post by Altella
Hi Altella,

Which version of Ubuntu do you have?

* Altella <[hidden email]> [2014-01-30 00:49]:
> I have added the repository, and done the update, but when installing using:
> sudo apt-get install libpcl-all

Can you try sudo aptitude instlal libpcl-all? It should give you the
list of conflicting packages.

> I receive errors (I have the console in Spanish, I translate the messages,
> maybe no are exactly the same in English):

Just do export LANG=C to get the English output.

Cheers Jochen

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users

signature.asc (836 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems installing PCL 1.7.1 using PPA and Ubuntu

Altella
Thank you Jochen and Victor...

First of all I am using Ubuntu 12.04 LTS x64.

Following your instructions and reading the forums indicated, I have new errors so far:

1.- Using sudo apt-get -f  install libpcl-all:  I obtain exactly the same errors.

2.- Detecting actual Held packages in the system by:
 dpkg --get-selections | grep hold
gives an empty response, so apparently, there are not held packages.

3.- Finally, trying to use aptitude to install:
sudo aptitude install libpcl-all

says:
The following NEW packages will be installed:
  libflann-dev{a} libflann1{a} libpcl-1.7-all{a} libpcl-1.7-all-dev{a} libpcl-1.7-bin{a} libpcl-1.7-doc{a} libpcl-all libpcl-apps-1.7{a} libpcl-apps-1.7-dev{a} libpcl-common-1.7{a} libpcl-common-1.7-dev{a}
  libpcl-features-1.7{a} libpcl-features-1.7-dev{a} libpcl-filters-1.7{a} libpcl-filters-1.7-dev{a} libpcl-geometry-1.7-dev{a} libpcl-io-1.7{a} libpcl-io-1.7-dev{a} libpcl-kdtree-1.7{a} libpcl-kdtree-1.7-dev{a}
  libpcl-keypoints-1.7{a} libpcl-keypoints-1.7-dev{a} libpcl-octree-1.7{a} libpcl-octree-1.7-dev{a} libpcl-outofcore-1.7{a} libpcl-outofcore-1.7-dev{a} libpcl-people-1.7{a} libpcl-people-1.7-dev{a} libpcl-recognition-1.7{a}
  libpcl-recognition-1.7-dev{a} libpcl-registration-1.7{a} libpcl-registration-1.7-dev{a} libpcl-sample-consensus-1.7{a} libpcl-sample-consensus-1.7-dev{a} libpcl-search-1.7{a} libpcl-search-1.7-dev{a}
  libpcl-segmentation-1.7{a} libpcl-segmentation-1.7-dev{a} libpcl-surface-1.7{a} libpcl-surface-1.7-dev{a} libpcl-tracking-1.7{a} libpcl-tracking-1.7-dev{a} libpcl-visualization-1.7{a} libpcl-visualization-1.7-dev{a}
  libvtk5-qt4-dev{a} libvtk5.8-qt4{a} openni-dev{a} ps-engine{ab}
0 packages upgraded, 48 newly installed, 0 to remove and 1 not upgraded.
Need to get 53,8 MB of archives. After unpacking 245 MB will be used.
The following packages have unmet dependencies:
 ps-engine : Depends: openni-dev (>= 1.5.2.23~precise) but 1.3.2.1-4+precise2 is to be installed.
 libopenni0 : Conflicts: openni-dev but 1.3.2.1-4+precise2 is to be installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      libpcl-1.7-all [Not Installed]                    
2)      libpcl-1.7-all-dev [Not Installed]                
3)      libpcl-1.7-bin [Not Installed]                    
4)      libpcl-all [Not Installed]                        
5)      libpcl-apps-1.7-dev [Not Installed]                
6)      libpcl-io-1.7 [Not Installed]                      
7)      libpcl-io-1.7-dev [Not Installed]                  
8)      libpcl-outofcore-1.7-dev [Not Installed]          
9)      libpcl-people-1.7-dev [Not Installed]              
10)     libpcl-recognition-1.7-dev [Not Installed]        
11)     libpcl-visualization-1.7 [Not Installed]          
12)     libpcl-visualization-1.7-dev [Not Installed]      
13)     openni-dev [Not Installed]                        
14)     ps-engine [Not Installed]                          



Accept this solution? [Y/n/q/?]

And, of course, if you agree, It does not install anything...any other clue?

Thank you very much in advance !!!

Reply | Threaded
Open this post in threaded view
|

Re: Problems installing PCL 1.7.1 using PPA and Ubuntu

Jochen Sprickerhof
Administrator
Hi Altella,

* Altella <[hidden email]> [2014-01-30 08:08]:
> The following packages have unmet dependencies:
>  ps-engine : Depends: openni-dev (>= 1.5.2.23~precise) but
> 1.3.2.1-4+precise2 is to be installed.
>  libopenni0 : Conflicts: openni-dev but 1.3.2.1-4+precise2 is to be
> installed.

apt-get remove libopenni0.

Cheers Jochen

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users

signature.asc (836 bytes) Download Attachment