Problem about two Kinect v2 sensors with two PC via winsock

classic Classic list List threaded Threaded
1 message Options
Max
Reply | Threaded
Open this post in threaded view
|

Problem about two Kinect v2 sensors with two PC via winsock

Max
Hi, everyone
I want to use two Kinect v2 sensors and two PC (one Kinect connect to one
PC) to realize real-time. The step with my method is: (Kinect No.2 connected
to PC-Client) send Point Cloud to (Kinect No.1 connected to PC-Server) via
winsock. Before realizing this method, I tried the codes which didn't
include SDK or library of Kinect. (The codes are as the following:
Socket_Example.rar
<http://www.pcl-users.org/file/t498157/Socket_Example.rar>  ) The results of
the winsock codes could work. (Here are the images of the results:
<http://www.pcl-users.org/file/t498157/Server.jpg> ,
<http://www.pcl-users.org/file/t498157/Client.png> ) The server and the
client could connect. However, when I used the same codes and included SDK
or library of Kinect, (The codes are as the following:
Socket_Example(include_Kinect_SDK_library).rar
<http://www.pcl-users.org/file/t498157/Socket_Example%28include_Kinect_SDK_library%29.rar>
) the results of the winsock codes couldn't work. (Here are the images of
the results:  <http://www.pcl-users.org/file/t498157/Server_kinect.jpg> ,
<http://www.pcl-users.org/file/t498157/Client_kinect.png> ) The difference
between two groups is the CmakeLists code. I wonder why these different
results occurred and how to fix them.
Any help is appreciated.

Thank you very much!
Max



--
Sent from: http://www.pcl-users.org/
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users