PCL installation on windows 7

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

PCL installation on windows 7

mozendi
Hello,

I am trying to install PCL on windows 7 64 bit with Visual Studio 2010. I did exactly the same as instructed in http://www.pointclouds.org/documentation/tutorials/compiling_pcl_windows_3rdparty_installers.php#compiling-pcl-windows-3rdparty-installers. I did not get any error messages from CMake everything seems OK. Then I built the ALL_BUILD and I got a bunch of error messages (Build: 45 succeeded, 134 failed, 0 up-to-date, 0 skipped). I checked error messages and they are either (LINK : fatal error LNK1104: cannot open file '..\lib\pcl_io_debug.lib') or (LINK : fatal error LNK1104: cannot open file '..\lib\pcl_visualization_debug.lib').
Could you please help me about solving this installation problem?
Thanks in advance

Mustafa
Reply | Threaded
Open this post in threaded view
|

Re: PCL installation on windows 7

zidan001
This post has NOT been accepted by the mailing list yet.
hi,
 
   i have the same problems, have you solved it?

   thanks!
Reply | Threaded
Open this post in threaded view
|

Re: PCL installation on windows 7

brotherxiang00
Hi, I also have these problems. Do you find how to solve them? Many thanks.
Reply | Threaded
Open this post in threaded view
|

Re: PCL installation on windows 7

kwaegel
Administrator
In reply to this post by mozendi
Can you attach a copy of the build log showing all the errors? The "LNK1104: cannot open file" error just says one of the earlier build steps failed, not what caused the failure.
Reply | Threaded
Open this post in threaded view
|

Re: PCL installation on windows 7

brotherxiang00
Hi, the logs of CMake and Build are attached. Many thanks.Result_CMake.txtResult_Build.txt
Reply | Threaded
Open this post in threaded view
|

Re: PCL installation on windows 7

kwaegel
Administrator
Wow. That build log makes no sense to me, and it looks like messages from multiple build targets are interleaved.

Try building only pcl_io (right click>build) and post that log. Hopefully that will build in strict dependency order and avoid the out-of-order log messages. In fact, based on the dependency tree from this page, you could try unloading all projects except pcl_common, pcl_io_ply, and pcl_io just to get a cleaner log.