PCL Official Site Out of Date Ubuntu PPA

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

PCL Official Site Out of Date Ubuntu PPA

danieltak
This post was updated on .
Accessing the  PPA link
<https://launchpad.net/~v-launchpad-jochen-sprickerhof-de/+archive/ubuntu/pcl
gives the following message:/This only exists for history reasons. Please
use the PCL version included in Ubuntu:sudo apt install libpcl-dev/So do I
use this aptitude package to install PCL? Shouldn`t it be updated on the
official site?And when I install this package. Does all prerequisites come
together? Cross-posting <https://askubuntu.com/q/979146/721545> , PPA seems to be out of date/ deprecated

--
Sent from: http://www.pcl-users.org/
_______________________________________________
PCL-users@pointclouds.org / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL Official Site Out of Date Ubuntu PPA

Sérgio Agostinho
Don't add that PPA. Just use what is distributed by default on Ubuntu.

https://packages.ubuntu.com/search?keywords=libpcl-dev&searchon=names&suite=all&section=all

> I am an Ubuntu Newbie.
>
>   Does all prerequisites come with the distributed default on Ubuntu?
> Or do I have to :
>
> sudo apt -y install g++ cmake cmake-gui doxygen mpi-default-dev openmpi-bin openmpi-common libusb-1.0-0-dev libqhull* libusb-dev libgtest-dev
> sudo apt -y install git-core freeglut3-dev pkg-config build-essential libxmu-dev libxi-dev libphonon-dev libphonon-dev phonon-backend-gstreamer
> sudo apt -y install phonon-backend-vlc graphviz mono-complete qt-sdk libflann-dev

Aptitude installs all required dependencies.

Cheers

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

RES: PCL Official Site Out of Date Ubuntu PPA

danieltak
This post was updated on .
Thank You,

 I am an Ubuntu Newbie.

 Does all prerequisites come with the distributed default on Ubuntu?

Never did it and https://packages.ubuntu.com/xenial/libpcl-dev states some packages that libpcl-dev depends on.
So those packages comes installed? Or do I have to install before?

Best Regards,

EDIT:

Aptitude installs all required dependencies.

Didn`t read this part. Thanks for the answer, going to install everything now.

Daniel Takeshi
daniel.takeshi@similar.ind.br
Reply | Threaded
Open this post in threaded view
|

Re: RES: PCL Official Site Out of Date Ubuntu PPA

ROZAR Fabien
Hi M Takeshi,

As you are Ubuntu newbie, you can thrust blindly the apt-get stuff
(I do, and almost never get in trouble).

apt-get stuff do the job for you (installation of dependancies), it just
let you know what it does.

frozar

Le 22/11/2017 à 16:42, Daniel Takeshi a écrit :

> Thank You,
>
>   I am an Ubuntu Newbie.
>
>   Does all prerequisites come with the distributed default on Ubuntu?
>
> Never did it and https://packages.ubuntu.com/xenial/libpcl-dev states some packages that libpcl-dev depends on.
> So those packages comes installed? Or do I have to install before?
>
> Best Regards,
>
> Daniel Takeshi
> [hidden email]
>
> -----Mensagem original-----
> De: PCL-users [mailto:[hidden email]] Em nome de Sérgio Agostinho
> Enviada em: quarta-feira, 22 de novembro de 2017 13:36
> Para: [hidden email]
> Assunto: Re: [PCL-users] PCL Official Site Out of Date Ubuntu PPA
>
> Don't add that PPA. Just use what is distributed by default on Ubuntu.
>
> https://packages.ubuntu.com/search?keywords=libpcl-dev&searchon=names&suite=all&section=all
>
>> I am an Ubuntu Newbie.
>>
>>    Does all prerequisites come with the distributed default on Ubuntu?
>> Or do I have to :
>>
>> sudo apt -y install g++ cmake cmake-gui doxygen mpi-default-dev
>> openmpi-bin openmpi-common libusb-1.0-0-dev libqhull* libusb-dev
>> libgtest-dev sudo apt -y install git-core freeglut3-dev pkg-config
>> build-essential libxmu-dev libxi-dev libphonon-dev libphonon-dev
>> phonon-backend-gstreamer sudo apt -y install phonon-backend-vlc
>> graphviz mono-complete qt-sdk libflann-dev
> Aptitude installs all required dependencies.
>
> Cheers
>
> _______________________________________________
> [hidden email] / http://pointclouds.org http://pointclouds.org/mailman/listinfo/pcl-users
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users