PCL 1.0 deb wrong dependency "libqhull5"

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

PCL 1.0 deb wrong dependency "libqhull5"

lamuertepeluda
The new Ubuntu package provided at 


has a mistake in its dependencies that must be fixed (libqhull5 is written as lbqhull5 skipping an 'i') because prevents installation.

May be also 64-bit version could be affected. Please correct it.

Thank you,


Vito Macchia

_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

Jochen Sprickerhof
Administrator
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

lamuertepeluda
Hi Jochen,

I'm sorry but there is another problem with the pcl .deb now: I've installed libboost-all-dev and libboost1.42-all-dev (so also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my system, but Ubuntu Software Center complains about "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency cannot be satisfied". What does it mean?

I also noticed that, when installing the dependency packages made by you (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about packages not being "properly made" (I can't tell the exact message in English because I'm using the Italian version), but if I click "Install anyway" they install correctly.

Thank you


Vito

2011/5/10 Jochen Sprickerhof <[hidden email]>
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

nizar sallem
Hi Vito,

This means that you have libboost-filesystem installed at version 1.40 and you need libboost-system-1.42

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 9:57 AM, Vito Macchia wrote:

Hi Jochen,

I'm sorry but there is another problem with the pcl .deb now: I've installed libboost-all-dev and libboost1.42-all-dev (so also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my system, but Ubuntu Software Center complains about "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency cannot be satisfied". What does it mean?

I also noticed that, when installing the dependency packages made by you (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about packages not being "properly made" (I can't tell the exact message in English because I'm using the Italian version), but if I click "Install anyway" they install correctly.

Thank you


Vito

2011/5/10 Jochen Sprickerhof <[hidden email]>
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

lamuertepeluda
No Nizar, 

what I mean is I have only 1.42 version installed (everything, dev, metapackages... all boost packages) from the official Natty repository. I think 1.40 is no more available on 11.04 

Should I downgrade it to 1.40? Or it is just an Ubuntu Natty related problem?

Cheers

Vito




2011/5/11 Nizar Khalifa Sallem <[hidden email]>
Hi Vito,

This means that you have libboost-filesystem installed at version 1.40 and you need libboost-system-1.42

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 9:57 AM, Vito Macchia wrote:

Hi Jochen,

I'm sorry but there is another problem with the pcl .deb now: I've installed libboost-all-dev and libboost1.42-all-dev (so also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my system, but Ubuntu Software Center complains about "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency cannot be satisfied". What does it mean?

I also noticed that, when installing the dependency packages made by you (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about packages not being "properly made" (I can't tell the exact message in English because I'm using the Italian version), but if I click "Install anyway" they install correctly.

Thank you


Vito

2011/5/10 Jochen Sprickerhof <[hidden email]>
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users



_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

nizar sallem
Ah I understand better,
Then there is a problem with Natty and you should open a new issue on dev.pointclouds.org specifying that you have version 1.42 installed.

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 10:06 AM, Vito Macchia wrote:

No Nizar, 

what I mean is I have only 1.42 version installed (everything, dev, metapackages... all boost packages) from the official Natty repository. I think 1.40 is no more available on 11.04 <35F.gif>

Should I downgrade it to 1.40? Or it is just an Ubuntu Natty related problem?

Cheers

Vito




2011/5/11 Nizar Khalifa Sallem <[hidden email]>
Hi Vito,

This means that you have libboost-filesystem installed at version 1.40 and you need libboost-system-1.42

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 9:57 AM, Vito Macchia wrote:

Hi Jochen,

I'm sorry but there is another problem with the pcl .deb now: I've installed libboost-all-dev and libboost1.42-all-dev (so also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my system, but Ubuntu Software Center complains about "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency cannot be satisfied". What does it mean?

I also noticed that, when installing the dependency packages made by you (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about packages not being "properly made" (I can't tell the exact message in English because I'm using the Italian version), but if I click "Install anyway" they install correctly.

Thank you


Vito

2011/5/10 Jochen Sprickerhof <[hidden email]>
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

lamuertepeluda
Ok I'll do it right now! Thank you :)

2011/5/11 Nizar Khalifa Sallem <[hidden email]>
Ah I understand better,
Then there is a problem with Natty and you should open a new issue on dev.pointclouds.org specifying that you have version 1.42 installed.

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 10:06 AM, Vito Macchia wrote:

No Nizar, 

what I mean is I have only 1.42 version installed (everything, dev, metapackages... all boost packages) from the official Natty repository. I think 1.40 is no more available on 11.04 <35F.gif>

Should I downgrade it to 1.40? Or it is just an Ubuntu Natty related problem?

Cheers

Vito




2011/5/11 Nizar Khalifa Sallem <[hidden email]>
Hi Vito,

This means that you have libboost-filesystem installed at version 1.40 and you need libboost-system-1.42

Cheers,
--
Nizar SALLEM
Robotics and Artificial Intelligence PhD student
LAAS-CNRS
7, Avenue Colonel Roche
31077 Toulouse CEDEX 4
FRANCE




On May 11, 2011, at 9:57 AM, Vito Macchia wrote:

Hi Jochen,

I'm sorry but there is another problem with the pcl .deb now: I've installed libboost-all-dev and libboost1.42-all-dev (so also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my system, but Ubuntu Software Center complains about "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency cannot be satisfied". What does it mean?

I also noticed that, when installing the dependency packages made by you (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about packages not being "properly made" (I can't tell the exact message in English because I'm using the Italian version), but if I click "Install anyway" they install correctly.

Thank you


Vito

2011/5/10 Jochen Sprickerhof <[hidden email]>
Hello Vito,

* Vito Macchia <[hidden email]> [2011-05-10 18:45]:
> The new Ubuntu package provided at
>
> http://dev.pointclouds.org/attachments/download/185/PCL-1.0.0_i386.deb
>
> has a mistake in its dependencies that must be fixed (*libqhull5* is written
> as *lbqhull5* skipping an 'i') because prevents installation.
>
> May be also 64-bit version could be affected. Please correct it.

thanks a lot for noticing, I've just committed a bug fix. The new packages
will be available later today.

> Thank you,
>
>
> Vito Macchia

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users

_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users




_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users



_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: PCL 1.0 deb wrong dependency "libqhull5"

Jochen Sprickerhof
Administrator
In reply to this post by lamuertepeluda
* Vito Macchia <[hidden email]> [2011-05-11 09:57]:
> Hi Jochen,

Hi Vito,

> I'm sorry but there is another problem with the pcl .deb now: I've
> installed libboost-all-dev and libboost1.42-all-dev (so
> also libboost-filesystem1.42-dev and libboost-filesystem1.42.0) on my
> system, but Ubuntu Software Center complains about
> "libboost-filesystem1.40.0 ( >= libboost-filesystem1.40.0-1) dependency
> cannot be satisfied". What does it mean?

thanks for noticing, I've used Ubuntu 10.10 to build the packages which
had boost 1.40 as default.

> I also noticed that, when installing the dependency packages made by you
> (Eigen3,CMINPACK and FLANN) on Ubuntu 11.04 "Natty", UBS warned about
> packages not being "properly made" (I can't tell the exact message in
> English because I'm using the Italian version), but if I click "Install
> anyway" they install correctly.

I'm aware of this problem as well and I'm working on a proper solution.
At the moment we use cmake to build our Packages (which does not produce
proper packages). I've started to set up real Debian packages on a
Ubuntu PPA, so installing should become really easy.

> Thank you
>
>
> Vito

Cheers,

Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
https://code.ros.org/mailman/listinfo/pcl-users