Installing PCL with VTK 6.1.0 and boost 1.55.0

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing PCL with VTK 6.1.0 and boost 1.55.0

pawkro
Is there any way to install PCL and force it to use the newest VTK (6.1.0) and the newest Boost (1.55.0)? Thanks for the help in advance.

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

kwaegel
Administrator
pawkro wrote
Is there any way to install PCL and force it to use the newest VTK (6.1.0)
and the newest Boost (1.55.0)? Thanks for the help in advance.
I set the BOOST_ROOT and BOOST_LIBRARYDIR to the location of the the version I want to use, assuming you have multiple versions installed. If you only have 1.55.0 installed, it should find that without any additional work.

I believe VTK6 support is still a work in progress.
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

pawkro
VTK 6 suport is probably develoged on gtihub by guy known as fran6co. Has anyone of you tried this?

"If you want to make QT5 works with VTK 6.1.0. You have to download cmake files from GitHub. I'm not sure if the VTK fix is merged to master or not. But there's a branch with fixed which is fix by fran6co.
https://github.com/fran6co/pcl/tree/vtk6-fixes.bck "
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

Dabox
I tried a week ago and it was still not supported
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

pawkro
Some guy here:

http://www.pcl-users.org/PCL-Visualizer-crashes-on-Mac-OS-td4033682.html#a4033696

writes that he managed to compile PCL with VTK 6.1.0 :

"I'm using
boost-1.55.0
Eigen-3.2.1
flann-1.8.4
qhull-2012.1
VTK-6.1.0


Huang "

So, I think it is possible. What do you think?
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

Dabox
mmm why do you need the latest versions? I have everything working with vtk 5.10 and boost 1.55
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

KKyang
In reply to this post by pawkro
The PCL 1.7 master at GitHub miss two things when I try to build with VTK 6.1.
First one is VTK 6.1 support. I just checked and the fix is merge by now.
The other one is the QT support. I'm trying to get VTK 6.1 works cause QT change the way widgets work so VTK 5 doesn't work any more. You can find that although there is a file name pcl_find_qt5.cmake, it ISN'T linked to the CMakeList. I check the new master now and it seems fixed, too. If it still can't find QT 5, you might have to fix by yourself by letting the cmake list only find QT 5 instead of QT 4.
Other errors are only small problems usually different when compiling on different computers. It might cause by changing the default install path or different OS. The environment I'm building the library is Windows 8.1 Pro with MSVC 2010.

Huang
Reply | Threaded
Open this post in threaded view
|

Re: Installing PCL with VTK 6.1.0 and boost 1.55.0

VictorLamoine
Administrator
VTK 6 fixes pull request has just been merged, do not hesitate to update your local copy of PCL and test if it works fine for you:
https://github.com/PointCloudLibrary/pcl/commit/6b53ae24c451c8438a2283ad20f27ec2e91a8242

Bye!