GPU implementation when using windowsAllInOne Installer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

GPU implementation when using windowsAllInOne Installer

Olivier Hoel

Good morning PCL community !

 

I’m currently using PCL 1.8.1 on windows (10 / x64) for a professional project and I’d like to use GPU acceleration to speed up my computations on the big point cloud we have.

However I can’t find any gpu folder into my PCL installation, and none of the files described in the documentation related to GPU… I used the WindowsAllInOne installer found on github.

  • Is it because I don’t have CUDA toolkit (or other required library??) so the installer skip copying GPU-related files?
  • Or the installer doesn’t have gpu features by default and I have to build library from source?

 

Thanks for your help!

 

 

Olivier Hoel     
Software Developer, Aurecon
M +64 22 3281821
[hidden email] 

Level 2, Iwikau Building
93 Cambridge Terrace Christchurch New Zealand 8013
PO Box 1061, Christchurch 8140
aurecongroup.com 

 

 

DISCLAIMER


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: GPU implementation when using windowsAllInOne Installer

Sérgio Agostinho

On 25-01-2018 01:28, Olivier Hoel wrote:
Or the installer doesn’t have gpu features by default and I have to build library from source?


It's this one. The GPU module is not properly maintained at the moment, therefore consider it "experimental".

I recommend using vcpkg to install your dependencies. The appveyor script we use to run the unit tests should give you some tips on how what you need.

Cheers


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users

signature.asc (836 bytes) Download Attachment