Failed to build pcl_io from trunk

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Failed to build pcl_io from trunk

ziXet
Hi

My trunk revision is 6802.
When I want to build the pcl_io I get this error :
4>.../common/include\pcl/impl/point_types.hpp(259): error C2226: syntax error : unexpected type 'COLORREF'
4>.../common/include\pcl/impl/point_types.hpp(260): error C2334: unexpected token(s) preceding '{'; skipping apparent function body

Please help me.

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Failed to build pcl_io from trunk

Sergey
Administrator
Hi,

As far as I can see, PCL trunk has been in uncompilable state (for Windows) for quite a while now (check here). Depending on whether you are on 32-bit or 64-bit I would suggest you to update (for example) to revision 6768 or 6782 respectively. They both seem to compile, though fail some tests. If you do not need the very latest trunk, pick "the last successful build" from the aforementioned site.

Regards,
Sergey

Reply | Threaded
Open this post in threaded view
|

Re: Failed to build pcl_io from trunk

ziXet
Thanks Surgey!
I update the trunk to earlier version and it's working fine now!

Many thanks.