CUDA module for PCL 1.4.0-32bit

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

CUDA module for PCL 1.4.0-32bit

race
Hi everyone

I am not a big C++ fan but I have been using PCL1.4.0-32bit for a while and I have got used to it. I made some modification to the CUDA module by mistake and I wanted to revert back to the earlier modules. However when I did an svn checkout I ended up with the new CUDA modules. I really dont want ot use the newer 1.6.0 version... byu any chance does someone still have the older CUDA modules for PCL1.4-32bit?
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

Radu B. Rusu
Administrator
Feel free to use our SVN repository to pull out any PCL version you want: http://svn.pointclouds.org/pcl/tags/

Cheers,
Radu.
--
http://openperception.org

On 08/01/2012 07:53 PM, race wrote:

> Hi everyone
>
> I am not a big C++ fan but I have been using PCL1.4.0-32bit for a while and
> I have got used to it. I made some modification to the CUDA module by
> mistake and I wanted to revert back to the earlier modules. However when I
> did an svn checkout I ended up with the new CUDA modules. I really dont want
> ot use the newer 1.6.0 version... byu any chance does someone still have the
> older CUDA modules for PCL1.4-32bit?
>
>
>
> --
> View this message in context: http://www.pcl-users.org/CUDA-module-for-PCL-1-4-0-32bit-tp4021015.html
> Sent from the Point Cloud Library (PCL) Users mailing list archive at Nabble.com.
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
>
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

race
Hi Radu

Thanks for the message but the SVN repository does not seem to contain the CUDA modules for PCL1.4. Is there any other place from where I could get this module?
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

Radu B. Rusu
Administrator
Only SVN trunk then, using an old revision. You'd have to go back in the repository history around the time when we
forked for 1.4.

Cheers,
Radu.
--
http://openperception.org

On 08/02/2012 03:15 AM, race wrote:

> Hi Radu
>
> Thanks for the message but the SVN repository does not seem to contain the
> CUDA modules for PCL1.4. Is there any other place from where I could get
> this module?
>
>
>
> --
> View this message in context: http://www.pcl-users.org/CUDA-module-for-PCL-1-4-0-32bit-tp4021015p4021024.html
> Sent from the Point Cloud Library (PCL) Users mailing list archive at Nabble.com.
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
>
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

race
Thanks Radu

I've been trying to get the older branches... I found the revision history here...  http://dev.pointclouds.org/projects/pcl/repository/changes/trunk/cuda   but I am not sure how to download these changes. I am looking for the version around 19/1/2012.

Any help is welcome
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

Sergey
Administrator
Hi,

Just pick some revision number and update to it. For example, if you want revision 3936 you have to run:

svn update -r 3936

from the location where you have previously checked out the PCL trunk.

Regards,
Sergey
Reply | Threaded
Open this post in threaded view
|

Re: CUDA module for PCL 1.4.0-32bit

race
This post was updated on .
Thanks Sergey

got the version.
I've another problem now: I tried installing this but I get very strange errors: in debug version although everything compiles while running kinFu it gives me the message: "The application was unable to start correctly(0xc000000d)." The VS output shows: Kinfu-app-gd.exe: Native has exited with code -1073741811. just after loading pcl_common-gd.dll.
If I replace the pcl_common-gd.dll with its release version it continues untill it finds another pcl_gpu_containers-gd.dll and so on...
The release version crashes immediately on execution.

I am using VS2010, boost:1.47, eigen:3.0.5, flaan: 1.7.1 cudatoolkit: v4.0 and gpucudasdk: v4.0
GPU: GeForce GTX 580

can anybody help me?
I had installed the same version earlier without any problem but had to reformat my system recently :(