CMake Error

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

CMake Error

ayerhs7
I'm trying to install the kinfu app. I'm using windows 8.1 and visual studio 2010 express and I have downloaded and installed 64 bit 3rd party installers according to the following tutorial-
http://pointclouds.org/documentation/tutorials/compiling_pcl_windows.php#compiling-pcl-windows
When I tried to configure pcl using cmake-gui, I got this error message :
CMake Error at CMakeLists.txt:11 (project):
  Cannot enable 64-bit tools with Visual Studio 2010 Express.

  Install the Microsoft Windows SDK v7.1 to get 64-bit tools:

    http://msdn.microsoft.com/en-us/windows/bb980924.aspx


Configuring incomplete, errors occurred!
See also "C:/pcl/build/CMakeFiles/CMakeOutput.log".

I installed microsoft windows sdk v7.1 but it's still showing the same error. Please help.
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

VictorLamoine
Administrator
From what I remember Visual Studio Express doesn't support CUDA.
You need a standard version of Visual Studio to get CUDA support.

Maybe the community edition supports it; you'll have to check:
https://www.visualstudio.com/fr-fr/products/visual-studio-community-vs.aspx

2015-10-27 4:54 GMT+01:00 ayerhs7 <[hidden email]>:
I'm trying to install the kinfu app. I'm using windows 8.1 and visual studio
2010 express and I have downloaded and installed 64 bit 3rd party installers
according to the following tutorial-
http://pointclouds.org/documentation/tutorials/compiling_pcl_windows.php#compiling-pcl-windows
When I tried to configure pcl using cmake-gui, I got this error message :
CMake Error at CMakeLists.txt:11 (project):
  Cannot enable 64-bit tools with Visual Studio 2010 Express.

  Install the Microsoft Windows SDK v7.1 to get 64-bit tools:

    http://msdn.microsoft.com/en-us/windows/bb980924.aspx


Configuring incomplete, errors occurred!
See also "C:/pcl/build/CMakeFiles/CMakeOutput.log".

I installed microsoft windows sdk v7.1 but it's still showing the same
error. Please help.



--
View this message in context: http://www.pcl-users.org/CMake-Error-tp4039800.html
Sent from the Point Cloud Library (PCL) Users mailing list mailing list archive at Nabble.com.
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users


_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

ayerhs7
Yes, after selecting "Visual Studio 2010" instead of "Visual Studio 2010 Win64" as the current generator in CMake, it configured successfully. Thank you.
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

ayerhs7
In reply to this post by VictorLamoine
I successfully built PCL using this tutorial :
http://pointclouds.org/documentation/tutorials/compiling_pcl_windows.php#
but there's no file called kinfu_app there. Please help me.
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

VictorLamoine
Administrator
Make sure CUDA and apps are enabled in CMake configuration, then configure again and make sure that kinfu_app is set to be built.
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

ayerhs7
I finally got CUDA in the CMake list and configured and generated the pcl.sln file but when i open solution explorer in pcl.sln, there's no kinfu app there. However, there is a file called pcl_gpu_kinfu as well as pcl_gpu_kinfu_large_scale. I built pcl_gpu_kinfu but that did not create the required kinfu.exe file in the pcl folder where pcl.sln was created. Please help.
Reply | Threaded
Open this post in threaded view
|

Re: CMake Error

ayerhs7
In reply to this post by VictorLamoine
In CMake I checked the BUILD_gpu_kinfu and BUILD_gpu_kinfu_large_scale boxes and configured and generated it. In the pcl.sln file generated by cmake, I found pcl_gpu_kinfu and pcl_gpu_kinfu_large_scale and I built them and then built the INSTALL file. This generated several .dll , .ilk , .pdb files and pcl_pcd_convert_NaN_nan_debug.exe and pcl_plyheader_debug.exe in the pcl\build\bin folder but kinfu_app.exe is not present. What could I have missed out?