Boost filesystem version 2 is now deprecated

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Boost filesystem version 2 is now deprecated

MiguelPF
Hi,

I was compiling PCL from trunk and installing all the dependencies by hand and found a problem with the boost libraries,
PCL-visualization uses the library filesystem, version 2, from Boost. It is now deprecated and do not work with the most recent version of Boost(1.50.0). The firs error I run into, is related with a macro defined in pcl something like BOOST_FILESYSTEM_VERSION=2, I change this macro and solve that error, but this do not solve the problem, because the names of some methods have changed.

This can be read in the filesystem web page
"This is Version 3 of the Filesystem library. Version 2 is not longer supported. 1.49.0 was the last release of Boost to supply Version 2"

May I suggest that the http://pointclouds.org/downloads/source.html page is change to advice this incompatibility,
or even better would be to move to filesystem v3.

Best regards

Reply | Threaded
Open this post in threaded view
|

Re: Boost filesystem version 2 is now deprecated

Jochen Sprickerhof
Administrator
* MiguelPF <[hidden email]> [2012-06-29 16:40]:
> Hi,

Hi MiguelPF,

> I was compiling PCL from trunk and installing all the dependencies by hand
> and found a problem with the boost libraries,
> PCL-visualization uses the library filesystem, version 2, from Boost. It is
> now deprecated and do not work with the most recent version of
> Boost(1.50.0). The firs error I run into, is related with a macro defined in
> pcl something like BOOST_FILESYSTEM_VERSION=2, I change this macro and solve
> that error, but this do not solve the problem, because the names of some
> methods have changed.
>
> This can be read in the filesystem web page
> "This is Version 3 of the Filesystem library. Version 2 is not longer
> supported. 1.49.0 was the last release of Boost to supply Version 2"
>
> May I suggest that the http://pointclouds.org/downloads/source.html page is
> change to advice this incompatibility,
> or even better would be to move to filesystem v3.

Can you please open a bug on the tracker: http://dev.pointclouds.org/.

> Best regards

Thanks, Jochen
_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Boost filesystem version 2 is now deprecated

MiguelPF
Hi Jochen,

I can not open a bug in the tracker because I am not in the contributors list,
can you please tell me what I should do to be in that list?
 I am registered  in the tracker as MiguelPF

Best Regards


2012/6/30 Jochen Sprickerhof <[hidden email]>
* MiguelPF <[hidden email]> [2012-06-29 16:40]:
> Hi,

Hi MiguelPF,

> I was compiling PCL from trunk and installing all the dependencies by hand
> and found a problem with the boost libraries,
> PCL-visualization uses the library filesystem, version 2, from Boost. It is
> now deprecated and do not work with the most recent version of
> Boost(1.50.0). The firs error I run into, is related with a macro defined in
> pcl something like BOOST_FILESYSTEM_VERSION=2, I change this macro and solve
> that error, but this do not solve the problem, because the names of some
> methods have changed.
>
> This can be read in the filesystem web page
> "This is Version 3 of the Filesystem library. Version 2 is not longer
> supported. 1.49.0 was the last release of Boost to supply Version 2"
>
> May I suggest that the http://pointclouds.org/downloads/source.html page is
> change to advice this incompatibility,
> or even better would be to move to filesystem v3.

Can you please open a bug on the tracker: http://dev.pointclouds.org/.

> Best regards

Thanks, Jochen



--
Miguel Pousa Freire
Email: [hidden email]
Phone: 673095341
LinkedIn: http://www.linkedin.com/pub/miguel-pousa-freire/33/146/839




_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Boost filesystem version 2 is now deprecated

aichim
Administrator
Hi,

You are now a contributor. :-)

Cheers,
Alex

On 6/30/12 11:39 AM, Miguel Pousa Freire wrote:
Hi Jochen,

I can not open a bug in the tracker because I am not in the contributors list,
can you please tell me what I should do to be in that list?
 I am registered  in the tracker as MiguelPF

Best Regards


2012/6/30 Jochen Sprickerhof <[hidden email]>
* MiguelPF <[hidden email]> [2012-06-29 16:40]:
> Hi,

Hi MiguelPF,

> I was compiling PCL from trunk and installing all the dependencies by hand
> and found a problem with the boost libraries,
> PCL-visualization uses the library filesystem, version 2, from Boost. It is
> now deprecated and do not work with the most recent version of
> Boost(1.50.0). The firs error I run into, is related with a macro defined in
> pcl something like BOOST_FILESYSTEM_VERSION=2, I change this macro and solve
> that error, but this do not solve the problem, because the names of some
> methods have changed.
>
> This can be read in the filesystem web page
> "This is Version 3 of the Filesystem library. Version 2 is not longer
> supported. 1.49.0 was the last release of Boost to supply Version 2"
>
> May I suggest that the http://pointclouds.org/downloads/source.html page is
> change to advice this incompatibility,
> or even better would be to move to filesystem v3.

Can you please open a bug on the tracker: http://dev.pointclouds.org/.

> Best regards

Thanks, Jochen



--
Miguel Pousa Freire
Email: [hidden email]
Phone: 673095341
LinkedIn: http://www.linkedin.com/pub/miguel-pousa-freire/33/146/839





_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users



_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users
Reply | Threaded
Open this post in threaded view
|

Re: Boost filesystem version 2 is now deprecated

Radu B. Rusu
Administrator
In reply to this post by MiguelPF
Miguel,

I fixed this last night. Thanks a lot for reporting the error!

Cheers,
Radu.


On 06/30/2012 02:39 AM, Miguel Pousa Freire wrote:

> Hi Jochen,
>
> I can not open a bug in the tracker because I am not in the contributors list,
> can you please tell me what I should do to be in that list?
>   I am registered  in the tracker as MiguelPF
>
> Best Regards
>
>
> 2012/6/30 Jochen Sprickerhof <[hidden email] <mailto:[hidden email]>>
>
>     * MiguelPF <[hidden email] <mailto:[hidden email]>> [2012-06-29 16:40]:
>      > Hi,
>
>     Hi MiguelPF,
>
>      > I was compiling PCL from trunk and installing all the dependencies by hand
>      > and found a problem with the boost libraries,
>      > PCL-visualization uses the library filesystem, version 2, from Boost. It is
>      > now deprecated and do not work with the most recent version of
>      > Boost(1.50.0). The firs error I run into, is related with a macro defined in
>      > pcl something like BOOST_FILESYSTEM_VERSION=2, I change this macro and solve
>      > that error, but this do not solve the problem, because the names of some
>      > methods have changed.
>      >
>      > This can be read in the filesystem web page
>      > "This is Version 3 of the Filesystem library. Version 2 is not longer
>      > supported. 1.49.0 was the last release of Boost to supply Version 2"
>      >
>      > May I suggest that the http://pointclouds.org/downloads/source.html page is
>      > change to advice this incompatibility,
>      > or even better would be to move to filesystem v3.
>
>     Can you please open a bug on the tracker: http://dev.pointclouds.org/.
>
>      > Best regards
>
>     Thanks, Jochen
>     _______________________________________________
>     [hidden email] <mailto:[hidden email]> / http://pointclouds.org
>     http://pointclouds.org/mailman/listinfo/pcl-users
>
>
>
>
> --
> Miguel Pousa Freire
> Email: [hidden email] <mailto:[hidden email]>
> Phone: 673095341
> LinkedIn: http://www.linkedin.com/pub/miguel-pousa-freire/33/146/839
>
>
>
>
>
> _______________________________________________
> [hidden email] / http://pointclouds.org
> http://pointclouds.org/mailman/listinfo/pcl-users
>

_______________________________________________
[hidden email] / http://pointclouds.org
http://pointclouds.org/mailman/listinfo/pcl-users